lkjb QRange

VST, AU, etc. plug-in Virtual Effects discussion
Izak Synthiemental
KVRian
611 posts since 4 Aug, 2010

Post Tue Sep 10, 2019 6:12 am

kingozrecords wrote:
Mon Sep 09, 2019 11:33 am
Has there been an update to this? The latency is far too overpowering on the version I have tested.
In short: there is no way around latency in the Linear Phase domain. Hence, such eqs are mostly used for mastering, where latency does not really matter.
http://soundcloud.com/samaritageto

Proper Education Always Corrects Errors

User avatar
Christian_D
KVRist
44 posts since 6 Aug, 2015

Re: lkjb QRange

Post Fri Sep 13, 2019 11:31 am

Hey man, just thought you might want to know your cool plug-in QRange 1.0.3 does not validate here with logic 10.3.3 / 10.11.6

All your other ones with the latest version validate and work fine though including QRange 1.0.0

Thanks for the free plugins!

lkjb
KVRist
152 posts since 13 Oct, 2012

Re: lkjb QRange

Post Fri Sep 13, 2019 11:24 pm

I thought I fixed the failing validation but I didn't put it in a new version number as the fix was the only thing that changed and I added the fix shortly after the 1.0.3 release. Can you check whether it also fails when using the current 1.0.3?

User avatar
Christian_D
KVRist
44 posts since 6 Aug, 2015

Re: lkjb QRange

Post Sat Sep 14, 2019 5:35 pm

Re-downloaded and AU validation is happy once again. Thank you kind sir!

lkjb
KVRist
152 posts since 13 Oct, 2012

Re: lkjb QRange

Post Sun Sep 22, 2019 1:21 am

Version 1.1.0 is now available. Besides fixing the default settings (overwriting didn't work) and saving latency mode (QRange would always load with Long latency setting) it also introduces a latency free minimal phase mode that can be selected via the latency setting.

s28
KVRist
340 posts since 9 Aug, 2017

Re: lkjb QRange

Post Sun Sep 22, 2019 2:35 am

lkjb wrote:
Sun Sep 22, 2019 1:21 am
Version 1.1.0 is now available. Besides fixing the default settings (overwriting didn't work) and saving latency mode (QRange would always load with Long latency setting) it also introduces a latency free minimal phase mode that can be selected via the latency setting.
This has made my day, the minimum phase mode with the analyser switched off uses not much cpu on my laptop and is totally usable as a go to eq plugin.

The save as default still isn't working though. I'm on Live 10, win8 vst2..... the latency is set to long still even when I've saved it as minimum phase, I think the analyser settings are resetting as well but will check again when I get a chance. If you can get this feature working this will be my go to eq for sure. Incredible gift to the freeware world, anywhere I can donate?

lkjb
KVRist
152 posts since 13 Oct, 2012

Re: lkjb QRange

Post Sun Sep 22, 2019 4:24 am

s28 wrote:
Sun Sep 22, 2019 2:35 am
The save as default still isn't working though. I'm on Live 10, win8 vst2..... the latency is set to long still even when I've saved it as minimum phase, I think the analyser settings are resetting as well but will check again when I get a chance. If you can get this feature working this will be my go to eq for sure. Incredible gift to the freeware world, anywhere I can donate?
OK, I somehow managed to test the "fixed" default settings but missed that they didn't work that well. Besides the latency setting not being set correctly, all bands will come up as peak filters as well.

The analyser setting isn't saved in the defaults as these should rather represent the EQ dsp state. Might be useful, though. I'll have a look...

lkjb
KVRist
152 posts since 13 Oct, 2012

Re: lkjb QRange

Post Sun Sep 22, 2019 5:25 am

Defaults should now be fixed for real. :)
I also added an option for the analyser to only be processed while the user interface is showing which should save some CPU, especially when using multiple instances.

s28
KVRist
340 posts since 9 Aug, 2017

Re: lkjb QRange

Post Sun Sep 22, 2019 6:10 am

lkjb wrote:
Sun Sep 22, 2019 5:25 am
Defaults should now be fixed for real. :)
I also added an option for the analyser to only be processed while the user interface is showing which should save some CPU, especially when using multiple instances.
Working perfectly. Thanks so much for this :)

lkjb
KVRist
152 posts since 13 Oct, 2012

Re: lkjb QRange

Post Fri Sep 27, 2019 11:40 pm

Version 1.1.2 fixes Cubase 10 crashing when changing the latency setting in the vst3 plugin on Windows.
It might also stop a short tail being played in Logic when turning the plugin off and on again. As I don't have Logic I couldn't test this. Also, as Logic only provides an on/off switch the audio will jump if a plugin introduces latency. Using the plugin's bypass button should thus be prefered.

sinkmusic
KVRAF
6258 posts since 28 Apr, 2004 from france

Re: lkjb QRange

Post Sat Sep 28, 2019 12:45 am

Thank you, LKBJ
Image

pc2000
KVRist
333 posts since 4 Apr, 2006

Re: lkjb QRange

Post Sat Sep 28, 2019 12:58 am

lkjb wrote:
Sun Sep 22, 2019 1:21 am
Version 1.1.0 is now available. Besides fixing the default settings (overwriting didn't work) and saving latency mode (QRange would always load with Long latency setting) it also introduces a latency free minimal phase mode that can be selected via the latency setting.
Many thanks for the minimal phase mode. 8)

sinkmusic
KVRAF
6258 posts since 28 Apr, 2004 from france

Re: lkjb QRange

Post Sat Sep 28, 2019 1:07 am

Would it be possible to have slightly bolder and unaliased eq curves at some point (a bit like Ozone's eq or TB eq4) ?
It makes everything more readable and more comfortable to use, imho.

Image

Image
Image

s28
KVRist
340 posts since 9 Aug, 2017

Re: lkjb QRange

Post Fri Oct 04, 2019 7:56 am

Used this on a track earlier and it works really well, very nice to work with.

I have one request - could you add 6db filters in there even if just to be used with the minimum phase mode, which is all i'm using.

Return to “Effects”