[Resolved] Troubles with Total Workstation 2 bundle

Official support for: sonicreality.com and esoundz.com
Schmidi
KVRist
202 posts since 23 Apr, 2011 from Seattle WA

Post Wed Mar 21, 2012 5:25 pm

Hi guys, I realize this is not the official IK forum but you all seem to be very competent with Sampletank (which I just recently bought after demoing it at a Guitar Center). I loved some of the sounds it came with and needed some "real world" bread and butter sounds for quick writing, and it seems great!

So far, I have been able to run it in standalone, but am having some real troubles trying to open it in a host app.

1. Where is the plug in version? I can't find a plug in version anywhere on my machine, nor on the factory discs?
-- I'm running Live 8.2.6 on W7 64bit.
-- I've rescanned my plugin folder, but I don't see anything from the TWS 2 bundle in the Live browser? (miroslav, SS2, sampletron, samplemoog, sampletank)
-- If I go through the windows explorer, I can only see a sampletank.exe (standalone) icon in my vst folder.
-- I have checked the manual but that's no good if I can't even see a plug version anywhere!

2. What is the best way to install the factory sound libraries?
-- I told the installers (one for each bundle instrument) to just install into one master folder, but now I see that the plugs don't differentiate libraries. Basically ALL sounds for all of them show in each plug in, but only a fraction of them open in the other plugs (sampletank aside). Makes searching for instruments tedious outside of sampletank.
-- Would it be better to make a separate folder for each of the bundle's library sounds?

3. Does the sampletank factory library include any COMBI/multi part patches?
-- could be that the way I installed the library, F'd up the file structure.

4. I've heard that importing and generating your own COMBI's can be a little slow in ST, is this true?
-- I'd love to make my own combi's with tempo sync'd loops and various zones/splits, but is it a ton more work than other samplers out there?

Any help you guys can provide would be very appreciated!

Schmidi

DarkStar
KVRAF
9264 posts since 2 Sep, 2003 from Surrey, UK

Post Wed Mar 21, 2012 11:48 pm

1. Where is the plug in version? I can't find a plug in version anywhere on my machine, nor on the factory discs?
-- the sampletank.exe file should not be in your VST folder, I would uninstall and start again.
-- the plugin is not a separate file of the install discs.
-- the scan in Live may fail if ST2 has not been installed completely and subsequently Live may ignore the plugin

It's been a long time since I installed ST2 I cannot recall all the details
-- most important is to run the Installers (and, later the Authorization Manager, and your DAW and the Standalone .exe files ) "as Administrator" - right-click the shortcut icon or .exe file and select it from the context menu.
-- run the ST2 installer as Administrator, most people select the default location for the program (the .exe file) and (a sub-folder in) their plugins folder for the VST (I think you can choose what plugin formats to install)
-- repeat for each of the other program installers
-- the plugin is not a separate file of the install discs.

2. What is the best way to install the factory sound libraries?
-- create a folder ...\IK Multimedia
-- install each library into a folder within there
...\IK Multimedia\SampleTank
...\IK Multimedia\Sonik Synth
etc
-- start the standalone version of each product (from the Start menu) and set each one to point at its own library
-- ST2 will open any of the instruments (so you could point it at the ..\IK Multimedia folder if you want), but the other products will only open their own library

3. Does the sampletank factory library include any COMBI/multi part patches?
-- yes: they are available from the "load" drop-down list at the top of the ST2 GUI.
-- they are located in a sub-folder alongside the program installation folder
-- SampleTron does not have nay (but a pack can be bought from eSoundz)

I've heard that importing and generating your own COMBI's can be a little slow in ST, is this true?
-- not especially
-- the first time you save a User preset (a change to a single instrument) the software rebuilds the cache file from your library so that may take a minute or two; subsequent saves are quicker.

Also there is an Ik Multimedia forum for the SampleTank-based products here:
http://www.ikmultimedia.com/forum/viewforum.php?f=12
DarkStar
Interesting, if true ...

Schmidi
KVRist
202 posts since 23 Apr, 2011 from Seattle WA

Post Thu Mar 22, 2012 5:00 am

Thank you for your response DarkStar (great John Carpenter movie BTW!). Thanks for the IK forum link too!

1. Where is the plug in version? I can't find a plug in version anywhere on my machine, nor on the factory discs?
-- the sampletank.exe file should not be in your VST folder, I would uninstall and start again.


So you are saying that I will have a folder with various ST2 files/folders, one of which is the standalone icon/launcher, but that should NOT be in my VST folder? How would Live open this file (irregardless of location)? It's not a VST/.dll that I can just drag into the Live browser.

I will try a default install (though it ONLY prompts for one install location, IE no plug in version install directory/location), using the administrator method.


2. What is the best way to install the factory sound libraries?
-- create a folder ...\IK Multimedia
-- install each library into a folder within there


Agreed, I'm doing it like this now.

#'s 3 and 4 should work out fine once I get 1 & 2 working!

Thanks for your help!

xamido
KVRian
1301 posts since 1 May, 2010

Post Thu Mar 22, 2012 5:03 am

Try to install and then run live as administrator. It won't read the .dll if you only run live normally

DarkStar
KVRAF
9264 posts since 2 Sep, 2003 from Surrey, UK

Post Thu Mar 22, 2012 5:51 am

Schmidi wrote:Thank you for your response DarkStar (great John Carpenter movie BTW!). Thanks for the IK forum link too!

1. Where is the plug in version? I can't find a plug in version anywhere on my machine, nor on the factory discs?
-- the sampletank.exe file should not be in your VST folder, I would uninstall and start again.


So you are saying that I will have a folder with various ST2 files/folders, one of which is the standalone icon/launcher, but that should NOT be in my VST folder? How would Live open this file (irregardless of location)? It's not a VST/.dll that I can just drag into the Live browser.

I will try a default install (though it ONLY prompts for one install location, IE no plug in version install directory/location), using the administrator method.
It's more Grateful Dead than John Carpenter ;)
Image

-- the program and other files (including the Combis) are installed in one folder
-- the VSTi is installed in another (selectable) folder (and you'll need to tell Live where that second folder is, so that it can find the VSTi)

Here are the screenshots from a relatively recent Sonik Synth 2 install on Windows 7:

Image
DarkStar
Interesting, if true ...

Schmidi
KVRist
202 posts since 23 Apr, 2011 from Seattle WA

Post Thu Mar 22, 2012 4:03 pm

Darkstar, I thank you VERY much for your thorough replies (with great pix no less!).

Looks like I must have clicked right through the 2nd browser/folder option when installing. The installer threw it into some obscure VST folder that was placed when I demoed Cubase at some point.

So, they are now where I want them and I shall go write some music! Thanks again for your help!

Schmidi

UPDATE

STILL WONT OPEN!


I have found the .dlls. but Live simply can not see them in the plug in folder!!!!

I've installed them as admin, I've run live as admin...NO LUCK!

xamido
KVRian
1301 posts since 1 May, 2010

Post Thu Mar 22, 2012 7:42 pm

Try to download the latest updates from their website. Most probably your installer is an older version.

Schmidi
KVRist
202 posts since 23 Apr, 2011 from Seattle WA

Post Thu Mar 22, 2012 8:17 pm

UPDATE 2

With your help and IK support, I have gotten all plugs working! It took a full uninstall, restart, running the installer as admin, then running live as admin to do it, but all is well now!

Thank you all for your help!

DarkStar
KVRAF
9264 posts since 2 Sep, 2003 from Surrey, UK

Post Fri Mar 23, 2012 1:04 am

^^^^
That's what I said ;)
Glad you're now up and running.

Remember to run the get the least Authorization Manager form IK Multimedia web site and run that as Administrator too.
DarkStar
Interesting, if true ...

Return to “Sonic Reality / eSoundz.com”