Need help installing drivers for IK Multimedia Stealth Pedal

Official support for: sonicreality.com and esoundz.com
Rockscientist
KVRer
7 posts since 5 Jan, 2010 from Seattle

Post Tue Jan 05, 2010 10:52 am

The 1.5.1 update does NOT solve this problem, but as bassman said there is a specific driver on the IK site that does; you just have to find it. I just got a SP today and was having the exact same problem until I downloaded the 64-bit Vista Stealthpedal driver found via this path (IK's site uses flash, so there is no direct link):

User Area -> Downloads -> Stealthpdeal, Related Downloads & HW Drivers

The original drivers that ship in the install disc are there, as well as new 32 and 64 bit drivers, as well as new 32 and 64 bit versions of the control program. I just installed the 64-bit driver on Win 7 x64 and did not get the "whether crashed or failed" message anymore. I then installed the 64-bit MIDI app and am rocking the Hendrix Wah 46 as I type. Hope this helps!

skwid12
KVRer
11 posts since 12 Aug, 2009

Post Wed Jan 06, 2010 11:38 am

i found a perfect way to fix this ..
1. uninstall stealth pedal drivers and uninstall, x gear
2. install guitar rig and guitar rig pedal
3.send the stealth pedal back to ik
4. ik goes bankrupt and now the employees bag groceries
5. you get what you pay for and no pros would use an unstable product like this :hihi:

skwid12
KVRer
11 posts since 12 Aug, 2009

Post Fri Jan 08, 2010 10:59 am

well just got off the phone with the managing director and man i will tell you , i wont spend another penny with this company, talk about useless help, or no help , and yes pete you included!!! long live the competition. if you want to use ik stuff live ,dont and you wont be embarrasssed as i was ,

asmilindog
KVRer
1 posts since 28 Jan, 2011

Post Thu Jan 27, 2011 11:28 pm

DID have the same installation problem. However, IK HAS supplied an updated 64 bit VISTA driver for Stealthplug as of January 2011. It is located in the userarea/downloads. When you go there it will show your product and will NOT show the updated driver. To get to the updated driver click the product name(it will be underlined)then click the button on the page which then appears called INFO. If that buttn does not show the updated driver click BACK and then click every button you cna find which is in the same row that lists your product. I downloaded the ZIP file to a NEW FOLDER on my desktop, unzipped it and there was an installstealthplug.exe file. Clicking that caused an install without a problem. Stealthplug install and the Amplitude2 install re both working and jamming is good. Just be sure and hook some headphones or speakers to the OUTPUT jack of the plug or you will think it is not working.

Return to “Sonic Reality / eSoundz.com”