Mac Bio,, Denormals, continuing saga, EDIT, i've given up, go to hell imageline.

Official support for: image-line.com
reflex
KVRian
850 posts since 3 Aug, 2001 from Belgium

Post Fri May 22, 2009 12:37 am

On March 5th, you said that the denormals problem had been fixed. Is this correct?

As for the downloader, please try the latest beta version if it's still giving problems:
http://forum.image-line.com/viewtopic.php?t=32863

ObsoleteAcc99
Banned
22486 posts since 5 Sep, 2001

Post Fri May 22, 2009 9:42 pm

as i said in that SAME post on March 5th

"And i spoke to soon. denormals still there with a vengeance on bass presets"

and you confirmed that nothing should have been different re denormals as toxic itself had not been updated.

No offence reflex but are you playing mind games with me?

If toxic hasn't been updated how could denormals have been fixed?

reflex
KVRian
850 posts since 3 Aug, 2001 from Belgium

Post Fri May 22, 2009 10:47 pm

The problem is that neither Maxx or I have been able to reproduce it, and as you know this topic has been going on for a while.

Is this still in Live? If so, could you create a small Live project that demonstrates the problem and upload it here?

ObsoleteAcc99
Banned
22486 posts since 5 Sep, 2001

Post Sat May 23, 2009 5:12 am

live and logic, au and vst. are you using intel or ppc processors?

reflex
KVRian
850 posts since 3 Aug, 2001 from Belgium

Post Sun May 24, 2009 10:21 pm

ttoz wrote:live and logic, au and vst. are you using intel or ppc processors?
I have Live and can test on both Intel and PPC.

ObsoleteAcc99
Banned
22486 posts since 5 Sep, 2001

Post Wed May 27, 2009 2:42 am

mate all you have to do is insert toxic on an empty live project, pick the first bass patch, hot a note, it will use next to no cpu, on release a second or so after, the cpu will shoot up to about 50% or so.

intel here (ppc are not subject to denormals, intels are)

reflex
KVRian
850 posts since 3 Aug, 2001 from Belgium

Post Wed May 27, 2009 3:12 am

I don't see any cpu spike when I try that.

Is it a single spike, or does it take longer for the cpu usage to go back down?

ObsoleteAcc99
Banned
22486 posts since 5 Sep, 2001

Post Thu May 28, 2009 10:24 am

no it's a fairly sustained spike which eventually goes down. do you have logic to try it in by any chance? i guess the best thing is to create a project like you said and send it to you.

reflex
KVRian
850 posts since 3 Aug, 2001 from Belgium

Post Thu May 28, 2009 11:23 am

I don't have Logic, no.

idolo1co
KVRist
103 posts since 14 Jul, 2005

Post Thu May 28, 2009 12:57 pm

post removed

ObsoleteAcc99
Banned
22486 posts since 5 Sep, 2001

Post Sat Jun 06, 2009 11:09 am

ok well i am pretty sure there is a logic express demo downloadable at apple which is efectively the same.


note, toxic is the ONLY plugin i am having denormal issues with and it was the same in live, but live is hit and miss for some reason.. maybe they added some low level noise in later versions to deal with general denormalization

reflex
KVRian
850 posts since 3 Aug, 2001 from Belgium

Post Sat Jun 06, 2009 12:21 pm

I can't find a demo version anywhere on Apple's website. I'll see if I can arrange something with someone at Apple though (but it will take a while even if it works).

Have you tried it in Garageband, btw? Cause I do have that installed.

User avatar
Chris Walton
KVRAF
2182 posts since 25 Jan, 2007 from the back room, away from his wife's sight (or so he thinks)

Post Sat Jun 06, 2009 12:53 pm

reflex, Does XCode support remote debugging? If so, you could set up a remote debugging session over the internet, add some denormal checks in certain places, and add breakpoints there so you can see where it's coming from. It'll be slow as hell over the internet, but it should work if XCode supports this.

It does require that both of you are awake and available at the same time though. Might be a bit difficult with a 9 hour time difference :)
Cakewalk by Bandlab / FL Studio
Squire Stratocaster / Chapman ML3 Modern V2 / Fender Precision Bass

Formerly known as arke, VladimirDimitrievich, bslf, and ctmg. Yep, those bans were deserved.

ObsoleteAcc99
Banned
22486 posts since 5 Sep, 2001

Post Fri Oct 23, 2009 6:43 pm

Here I go.... I just downloaded sawer demo.. and guess what, FIRST DEFAULT preset it loads up with.. in STUDIO ONE, NOT LOGIC, OK!

THAT IS WHAT A DENORMAL IS.. maybe MAxx needs to learn how to program? since he REFUSES to fix toxic biohazard.. and the same problem is present in sawer...

what a shame mac users are being ignored like this. How long have i been chasing a fix now, a year and a half? how about imageline refund me? you guys... really...


anyway two short videos will be uploaded soon.. one with sawer and one with toxic showing off the denormals.

ObsoleteAcc99
Banned
22486 posts since 5 Sep, 2001

Post Fri Oct 23, 2009 7:00 pm

OK!! for *some* reason, Ableton live doesn't do it, that's why you couldn't reproduce it. But Logic and studio one both do it. it IS a fault in the plugin, simply because out of the 157 components i have in my folder, only the IL stuff does it. I am GUESSING live has sone low level noise built in through the signal path by default to counter denormalization.....

ANYWAY, the complaint was that you couldn't get a demo of Logic, well you SURE CAN get a demo of studio one..!

so now there is no excuse not to fix it. Video's are coming....

Return to “Image Line”