Studio One Pro 4.5

Plug-in hosts and other software applications discussion
pk-1
KVRer
23 posts since 1 May, 2018

Post Tue Jul 02, 2019 10:30 am

simmo75 wrote:
Mon Jul 01, 2019 6:30 pm
Hi guys, i know 4.5 doesn’t have Komplete Kontrol mk2 integration yet but for some reason i cannot even use my s88 mk2 at all. I only want to be able to play and record midi key data but it just will not connect via MCU.
Don't know if I understand your problem, but as a MIDI keyboard, it should work just fine (add "KOMPLETE KONTROL - 1" as generic keyboard to your "External Devices").

Also, as of Komplete Kontrol 2.1.3, MCU is supported for the MK2 devices, making the Start/Stop/Record/Loop buttons work in S1 4.5.

simmo75
KVRian
1473 posts since 25 Mar, 2016 from Seattle

Re: Studio One Pro 4.5

Post Tue Jul 02, 2019 11:59 am

pk-1 wrote:
Tue Jul 02, 2019 10:30 am
simmo75 wrote:
Mon Jul 01, 2019 6:30 pm
Hi guys, i know 4.5 doesn’t have Komplete Kontrol mk2 integration yet but for some reason i cannot even use my s88 mk2 at all. I only want to be able to play and record midi key data but it just will not connect via MCU.
Don't know if I understand your problem, but as a MIDI keyboard, it should work just fine (add "KOMPLETE KONTROL - 1" as generic keyboard to your "External Devices").

Also, as of Komplete Kontrol 2.1.3, MCU is supported for the MK2 devices, making the Start/Stop/Record/Loop buttons work in S1 4.5.
Hey man, thanks for your reply.
It’s just not working for me, I tried Also mcu but that doesn’t work but every other daw it’s fine.

simmo75
KVRian
1473 posts since 25 Mar, 2016 from Seattle

Re: Studio One Pro 4.5

Post Tue Jul 02, 2019 3:11 pm

simmo75 wrote:
Tue Jul 02, 2019 11:59 am
pk-1 wrote:
Tue Jul 02, 2019 10:30 am
simmo75 wrote:
Mon Jul 01, 2019 6:30 pm
Hi guys, i know 4.5 doesn’t have Komplete Kontrol mk2 integration yet but for some reason i cannot even use my s88 mk2 at all. I only want to be able to play and record midi key data but it just will not connect via MCU.
Don't know if I understand your problem, but as a MIDI keyboard, it should work just fine (add "KOMPLETE KONTROL - 1" as generic keyboard to your "External Devices").

Also, as of Komplete Kontrol 2.1.3, MCU is supported for the MK2 devices, making the Start/Stop/Record/Loop buttons work in S1 4.5.
Hey man, thanks for your reply.
It’s just not working for me, I tried Also mcu but that doesn’t work but every other daw it’s fine.
EDIT : Got it working after updating the S88 firmware.

elnn
KVRist
302 posts since 4 Nov, 2011 from Tleat

Re: Studio One Pro 4.5

Post Wed Jul 03, 2019 3:13 am

Anyone getting crashes with 4.5.1? Or with Nektarine?…
Brzzzzzzt.

simmo75
KVRian
1473 posts since 25 Mar, 2016 from Seattle

Re: Studio One Pro 4.5

Post Tue Jul 09, 2019 7:49 am

Does anyone else have weird midi timing going on?

When I record a midi part, the recorded notes are playing back wrong, like Studio One is pushing the whole recording a 16th note forward. It's very strange behavior. Its not quantizing the notes.

User avatar
gentleclockdivider
KVRAF
2091 posts since 22 Mar, 2009 from gent

Re: Studio One Pro 4.5

Post Tue Jul 09, 2019 9:47 am

simmo75 wrote:
Tue Jul 09, 2019 7:49 am
Does anyone else have weird midi timing going on?

When I record a midi part, the recorded notes are playing back wrong, like Studio One is pushing the whole recording a 16th note forward. It's very strange behavior. Its not quantizing the notes.
Sure input quantize is turned off ?
Image

Edit : I just read more carefully , you say it pushes the whole recording a 16 th note forward , so the individual timing between the notes and the length is not altered then ?
Eyeball exchanging
Soul calibrating ..frequencies

simmo75
KVRian
1473 posts since 25 Mar, 2016 from Seattle

Re: Studio One Pro 4.5

Post Tue Jul 09, 2019 10:54 am

gentleclockdivider wrote:
Tue Jul 09, 2019 9:47 am
simmo75 wrote:
Tue Jul 09, 2019 7:49 am
Does anyone else have weird midi timing going on?

When I record a midi part, the recorded notes are playing back wrong, like Studio One is pushing the whole recording a 16th note forward. It's very strange behavior. Its not quantizing the notes.
Sure input quantize is turned off ?
Image

Edit : I just read more carefully , you say it pushes the whole recording a 16 th note forward , so the individual timing between the notes and the length is not altered then ?
Thanks for your reply. Quantize is definitely off, when i watch the recording its placing the all the notes too early, quite a lot too early, its weird.

Edit... Ok, so i changed the audio latency to 64 and it's fine now. So that's kind of odd that the audio buffer is changing my midi recording timing but not real time playing?

User avatar
gentleclockdivider
KVRAF
2091 posts since 22 Mar, 2009 from gent

Re: Studio One Pro 4.5

Post Tue Jul 09, 2019 1:04 pm

If I were you I would just create a topic on the presonus forum , big chance that it will get noticed by a beta tester who will report it further
Eyeball exchanging
Soul calibrating ..frequencies

Digivolt
KVRian
532 posts since 21 Nov, 2018

Re: Studio One Pro 4.5

Post Tue Jul 09, 2019 2:23 pm

Is there a way to have midi tracks that are controlling FX to never mute ? Gets annoying having to unmute them when I want to hear them working while soloing certain elements

daw.one
KVRist
85 posts since 16 Nov, 2016

Re: Studio One Pro 4.5

Post Wed Jul 10, 2019 4:06 am

Digivolt wrote:
Tue Jul 09, 2019 2:23 pm
Is there a way to have midi tracks that are controlling FX to never mute ? Gets annoying having to unmute them when I want to hear them working while soloing certain elements
Solo Safe (hold shift and press S(olo) on the track you want to keep from muting).

Digivolt
KVRian
532 posts since 21 Nov, 2018

Re: Studio One Pro 4.5

Post Wed Jul 10, 2019 5:39 am

daw.one wrote:
Wed Jul 10, 2019 4:06 am
Digivolt wrote:
Tue Jul 09, 2019 2:23 pm
Is there a way to have midi tracks that are controlling FX to never mute ? Gets annoying having to unmute them when I want to hear them working while soloing certain elements
Solo Safe (hold shift and press S(olo) on the track you want to keep from muting).
:tu: I guess it stays on forever until I do the key command again to turn it off ?

daw.one
KVRist
85 posts since 16 Nov, 2016

Re: Studio One Pro 4.5

Post Fri Jul 12, 2019 1:51 am

Digivolt wrote:
Wed Jul 10, 2019 5:39 am
daw.one wrote:
Wed Jul 10, 2019 4:06 am
]Solo Safe (hold shift and press S(olo) on the track you want to keep from muting).
:tu: I guess it stays on forever until I do the key command again to turn it off ?
Yes. It's the same behavior as Solo Safe on the sends.

apoclypse
KVRist
77 posts since 17 Oct, 2018

Re: Studio One Pro 4.5

Post Fri Jul 19, 2019 6:01 pm

simmo75 wrote:
Tue Jul 09, 2019 10:54 am
gentleclockdivider wrote:
Tue Jul 09, 2019 9:47 am
simmo75 wrote:
Tue Jul 09, 2019 7:49 am
Does anyone else have weird midi timing going on?

When I record a midi part, the recorded notes are playing back wrong, like Studio One is pushing the whole recording a 16th note forward. It's very strange behavior. Its not quantizing the notes.
Sure input quantize is turned off ?
Image

Edit : I just read more carefully , you say it pushes the whole recording a 16 th note forward , so the individual timing between the notes and the length is not altered then ?
Thanks for your reply. Quantize is definitely off, when i watch the recording its placing the all the notes too early, quite a lot too early, its weird.

Edit... Ok, so i changed the audio latency to 64 and it's fine now. So that's kind of odd that the audio buffer is changing my midi recording timing but not real time playing?
Did you have Low Latency mode turned on (its little Z in the Mixer Console Windows in the plugins section). That could explain what's going on. If you do have it on make sure to check that any plugin you have on the track or the master bus don't have/add latency (they will have green icons next to them in the Mixer Console).

Return to “Hosts & Applications (Sequencers, DAWs, Audio Editors, etc.)”