Structure - No Effects

Official support for: www.airmusictech.com
mnmlfrk
KVRist
102 posts since 3 Jun, 2008

Post Thu Jun 01, 2017 2:58 am

I do not have any effect parts or sends in Structure – some site recommended fixing permissions for a structure/settings folder, but i cannot find them... any ideas? macOS Sierra/VST&AU

mnmlfrk
KVRist
102 posts since 3 Jun, 2008

Re: Structure - No Effects

Post Thu Jun 15, 2017 4:35 am

well, i have contacted telephone support because the air website does not let me register my product in order to create support tickets..

sircuit
KVRian
503 posts since 15 Jul, 2016

Re: Structure - No Effects

Post Thu Dec 21, 2017 5:21 am

Same here seen it today, that's why I searched kvr for this problem: did you managed to find a fix?

Solution: Make sure the Structure folder contains the Settings folder (for some reason in my case it was installed one level up, in the Air Music Technology folder, the home of all plug-ins)

Edit:
- On macOS, Air products are installed in /Applications/Air Music Technology/
- Structure installs at /Applications/Air Music Technology/Structure/
- For some reason I had the Settings folder (belonging to Structure) in /Applications/Air Music Technology/ instead of /Applications/Air Music Technology/Structure/
- I moved the Settings folder to the proper path and now everytihg works fine.
 MacBook Pro Quad-Core _ macOS High Sierra __ ♫ Logic Pro X

Axxor
KVRer
11 posts since 12 Apr, 2013

Re: Structure - No Effects

Post Wed Jan 03, 2018 10:29 pm

Thanks a lot mate, you saved me.

I think there are a couple of rogue folders that got moved as well; 'Favorites' and 'imported Audio'.
But there is also 'Favorites' folder with an allias to 'Structure Factory Libraries' inside the Structure folder, I wonder if it's save to delete the allias because it points to a folder that is already inside 'Structure'?

Also, in case it helps someone out there; I always choose 'custom install' when available to save space because I only need AU (Audio Unit plugins), but some AIR plugins would only install the presets if you tick VST format.

I gotta say, the whole AIR install gave some troubles, it's been a while since...
You do not have the required permissions to view the files attached to this post.

User avatar
sureno
KVRian
743 posts since 4 May, 2008 from West London Depot

Re: Structure - No Effects

Post Sun Sep 23, 2018 9:42 am

having the same issue here but do we move the settings folder outside of "structure factory libraries" but inside of the overall structure folder?

sircuit
KVRian
503 posts since 15 Jul, 2016

Re: Structure - No Effects

Post Tue Oct 02, 2018 5:13 pm

"Structure Factory Libraries" can reside anywhere on the Disk (or external drive).

You really need to make sure that at this path /Applications/Air Music Technology/Structure/ you have at least a Settings folder (I also have one named Favorites) then inside this Settings folder you have the following folders: FX, Init, Midi and a file called Sine.wav

Image
 MacBook Pro Quad-Core _ macOS High Sierra __ ♫ Logic Pro X

User avatar
sureno
KVRian
743 posts since 4 May, 2008 from West London Depot

Re: Structure - No Effects

Post Thu Oct 04, 2018 2:45 pm

sircuit wrote:
Tue Oct 02, 2018 5:13 pm
"Structure Factory Libraries" can reside anywhere on the Disk (or external drive).

You really need to make sure that at this path /Applications/Air Music Technology/Structure/ you have at least a Settings folder (I also have one named Favorites) then inside this Settings folder you have the following folders: FX, Init, Midi and a file called Sine.wav

Image

Iv pretty much given up on this instrument, 2.0.7 doesn't make sound and 2.0.10 breaks db pathways :help: :(

sircuit
KVRian
503 posts since 15 Jul, 2016

Re: Structure - No Effects

Post Thu Oct 04, 2018 3:26 pm

2.0.10 under High Sierra works fine, you just have to make sure the folder structure in /Applications is as instructed above and when loading a patch, make sure the Midi Channel is Port A, Channel 1 (A1) so you can play it with the keyboard.
 MacBook Pro Quad-Core _ macOS High Sierra __ ♫ Logic Pro X

User avatar
sureno
KVRian
743 posts since 4 May, 2008 from West London Depot

Re: Structure - No Effects

Post Thu Oct 04, 2018 3:35 pm

sircuit wrote:
Thu Oct 04, 2018 3:26 pm
2.0.10 under High Sierra works fine, you just have to make sure the folder structure in /Applications is as instructed above and when loading a patch, make sure the Midi Channel is Port A, Channel 1 (A1) so you can play it with the keyboard.
it keeps wanting to scan my library though saying it has found new content and no longer loads the sine wave file? so if i install 2.0.10 and create the folder with contents "settings" it should work?

also when i say it plays no sound, it plays the sine wave but as soon as i play a preset, nothing

sircuit
KVRian
503 posts since 15 Jul, 2016

Re: Structure - No Effects

Post Thu Oct 04, 2018 3:47 pm

sureno wrote:
Thu Oct 04, 2018 3:35 pm
it keeps wanting to scan my library though saying it has found new content and no longer loads the sine wave file? so if i install 2.0.10 and create the folder with contents "settings" it should work?

also when i say it plays no sound, it plays the sine wave but as soon as i play a preset, nothing
You don't have to create the Settings folder, the folder is already on your drive (see the first post in this thread). You must ensure that is present at proper location and all the subfolders and their respective contents are also there - otherwise you will have no FX.

Best thing to do, remove structure folder from /Applications/ (as previously mentioned, you can have the database anywhere on the disk, no need to delete it) then reinstall, then check if the Settings folder is installed according to the picture screenshot.

Then navigate here (see picture below, database menu -> wrench key icon), remove any paths, add your factory path and it should work flawlessy.

Image

Additionally, go to Setup -> Content and set custom path for Imported samples
 MacBook Pro Quad-Core _ macOS High Sierra __ ♫ Logic Pro X

User avatar
sureno
KVRian
743 posts since 4 May, 2008 from West London Depot

Re: Structure - No Effects

Post Thu Oct 04, 2018 3:55 pm

sircuit wrote:
Thu Oct 04, 2018 3:47 pm
sureno wrote:
Thu Oct 04, 2018 3:35 pm
it keeps wanting to scan my library though saying it has found new content and no longer loads the sine wave file? so if i install 2.0.10 and create the folder with contents "settings" it should work?

also when i say it plays no sound, it plays the sine wave but as soon as i play a preset, nothing
You don't have to create the Settings folder, the folder is already on your drive (see the first post in this thread). You must ensure that is present at proper location and all the subfolders and their respective contents are also there - otherwise you will have no FX.

Best thing to do, remove structure folder from /Applications/ (as previously mentioned, you can have the database anywhere on the disk, no need to delete it) then reinstall, then check if the Settings folder is installed according to the picture screenshot.

Then navigate here (see picture below, database menu -> wrench key icon), remove any paths, add your factory path and it should work flawlessy.

Image

Additionally, go to Setup -> Content and set custom path for Imported samples


so as it stands i have done a fresh install to 2.0.7, with library on an external drive, so if i understand you correctly, i
check current pathways/content locations
delete the folder: /Applications/Air Music Technology/Structure
then install update to 2.0.10 and ensure all folders are present in the above pathway removing any new erroneous content locations?

sircuit
KVRian
503 posts since 15 Jul, 2016

Re: Structure - No Effects

Post Thu Oct 04, 2018 3:59 pm

Yep, that would be the steps.

After finishing installation, check if this folder exists: /Applications/Air Music Technology/Settings. Check it's content, if is similar to my screenshot, drag it inside /Applications/Air Music Technology/Structure folder. Then start the daw and load the plugin and do the database setting as illustrated in the second screenshot
 MacBook Pro Quad-Core _ macOS High Sierra __ ♫ Logic Pro X

User avatar
sureno
KVRian
743 posts since 4 May, 2008 from West London Depot

Re: Structure - No Effects

Post Thu Oct 04, 2018 4:02 pm

:clap: thanks man, will give this a spin in the morning
sircuit wrote:
Thu Oct 04, 2018 3:59 pm
Yep, that would be the steps.

After finishing installation, check if this folder exists: /Applications/Air Music Technology/Settings. Check it's content, if is similar to my screenshot, drag it inside /Applications/Air Music Technology/Structure folder. Then start the daw and load the plugin and do the database setting as illustrated in the second screenshot

Return to “AIR Music Technology”